Problèmes d'affichage sous xubuntu 18.04

il y a 2 mois 1 jour #20888 par Steph.LOUVRIER
Bonjour,

J'ai récemment migré mon PC portable sous xubuntu 18.04 (en passant par une réinstallation complète) et ce matin c'est la première que j'ouvre Noethys sur celui-ci.

Je rencontre un problème d'affichage : les "éphémérides" et les fiches familles (captures d'écrans en pièces jointes).

Je suppose qu'il me manque l'une des dépendances à installer avant l'utilisation de Noethys mais j'ai beau vérifier si elles sont bien toutes installées (il n'y a que python-imaging qui ne veut pas s'installer et qui est remplacé par python-pil) et relancer Noethys j'ai toujours le même problème.

Pour les éphémérides ce n'est pas trop grave mais pour l'afficahge dans les fiches familles c'est beaucoup plus dérangeant.

Un petit coup de main s'il vous plaît (Claude si vous êtes dans le coin ^^) ?

Bonne journée,
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

il y a 2 mois 1 jour #20894 par mairiedecoulogne
essaye sa :
sudo apt-get install python-paramiko

sudo apt-get install python-pil

Connexion ou Créer un compte pour participer à la conversation.

il y a 2 mois 12 heures #20897 par Steph.LOUVRIER

mairiedecoulogne écrit: essaye sa :
sudo apt-get install python-paramiko

sudo apt-get install python-pil

J'avais déjà vérifié que toutes les dépendances étaient bien installées mais j'ai quand même suivi votre conseil. J'en ai profité pour faire la dernière mise à jour de Noethys (la v1.2.4.8) et résultat : pas de changement :'(

Merci quand même.

Connexion ou Créer un compte pour participer à la conversation.

il y a 2 mois 6 heures #20900 par mairiedecoulogne
je vais essayer sur une vm en installant xubuntu et je vous tiens au courant.
Les utilisateur(s) suivant ont remercié: Steph.LOUVRIER

Connexion ou Créer un compte pour participer à la conversation.

il y a 1 mois 1 semaine #21059 par Steph.LOUVRIER
Bonjour,

Je relance un peu le sujet car il y a toujours ce problème d'affichage :(

Par avance merci

Connexion ou Créer un compte pour participer à la conversation.

il y a 1 mois 2 jours #21089 par Claude
Bonjour,

Effectivement je ne suis plus passé très régulièrement ces derniers temps.
Alors j'ai le même symptôme sur ma Debian, mais pas sur ma Mint.
J'ai bien vu une différence, c'est que la librairie graphique n'est pas compilée sur la même versio de gtk.

Peux-tu aller dans le menu outils administrateur, console python, et taper la commande:
wx.version()

Tu devrais avoir quelque chose de ce genre:
'3.0.2.0 gtk2 (classic)'

Sur la machine avec les problèmes d'affichage, j'ai gtk3 et non gtk2.
Dis moi chez toi comme c'est.

Ca ne me dira pas comment résoudre, mais ça me confirmera ma piste.

Et en attendant pout la fiche famille, tu peux passer en liste plutôt qu'en graphique (option d'affichage dans la fenêtre)

Claude
Les utilisateur(s) suivant ont remercié: Steph.LOUVRIER

Connexion ou Créer un compte pour participer à la conversation.

il y a 1 mois 2 jours #21093 par Steph.LOUVRIER

Claude écrit: Effectivement je ne suis plus passé très régulièrement ces derniers temps.

Pas de problème, on a tous nos préoccupations. Moi-même je dois reconnaître que je n'ai pas mis les pieds dans le forum depuis un petit moment.



Claude écrit: J'ai bien vu une différence, c'est que la librairie graphique n'est pas compilée sur la même versio de gtk.

Je me suis doutais qu'il y avait une histoire de librairie graphique car très clairement c'est une erreur au niveau de l'affichage. Mais n'étant pas (encore) spécialiste Linux, je ne savais pas comment tester mon intuition.



Claude écrit: Peux-tu aller dans le menu outils administrateur, console python, et taper la commande:
wx.version()

Tu devrais avoir quelque chose de ce genre:
'3.0.2.0 gtk2 (classic)'

Sur la machine avec les problèmes d'affichage, j'ai gtk3 et non gtk2.
Dis moi chez toi comme c'est.

Ca ne me dira pas comment résoudre, mais ça me confirmera ma piste.

La commande me retourne le même résultat que toi :
wx.version()
'3.0.2.0 gtk3 (classic)'



Claude écrit: Et en attendant pout la fiche famille, tu peux passer en liste plutôt qu'en graphique (option d'affichage dans la fenêtre)

Merci pour l'astuce mais je l'avais déjà trouvé. J'admet que j'ai oublié d'ne parler sur le forum :unsure:
Du coup mis à part l'heure et les éphémérides qui ne sont pas très visibles, j'arrive à me débrouiller pour le moment.

Merci pour la réponse, en espérant que cela puisse en aider d'autres en attendant une compilation avec la nouvelle bibliothèque gtk3.

Connexion ou Créer un compte pour participer à la conversation.

il y a 1 mois 2 jours #21095 par Ivan
Bonsoir,

Je te propose d'essayer d'installer la toute dernière version de wxpython (4.0.3). Elle est presque totalement compatible avec Noethys (j'y travaille depuis plusieurs années déjà !). Cela pourrait peut-être corriger le souci...

Ivan
Les utilisateur(s) suivant ont remercié: Steph.LOUVRIER

Connexion ou Créer un compte pour participer à la conversation.

il y a 1 mois 1 jour #21108 par Claude

Ivan écrit: Bonsoir,

Je te propose d'essayer d'installer la toute dernière version de wxpython (4.0.3). Elle est presque totalement compatible avec Noethys (j'y travaille depuis plusieurs années déjà !). Cela pourrait peut-être corriger le souci...

Ivan


Bonjour,

J'y ai songé, mais sous debian et ses dérivés, il semble que cette version ne soit proposée que pour python 3
Je vais regarder si je peux refaire la manip que j'avais faite à l'époque de la version 14 d'ubuntu, mettre en paquet une version qui fonctionne.
Mais avant ça je vais quand même rechercher ce qui entre gtk2 et gtk3 provoque ce symptôme.

Claude
Les utilisateur(s) suivant ont remercié: Steph.LOUVRIER

Connexion ou Créer un compte pour participer à la conversation.

il y a 1 mois 11 heures #21123 par Steph.LOUVRIER

Ivan écrit: Je te propose d'essayer d'installer la toute dernière version de wxpython (4.0.3). Elle est presque totalement compatible avec Noethys (j'y travaille depuis plusieurs années déjà !). Cela pourrait peut-être corriger le souci...

Je te remercie Ivan pour ta proposition mais j'avoue ne pas savoir comment faire car (x)Ubuntu mis dis que ma version gtk est déjà la plus récente.


Claude écrit: J'y ai songé, mais sous debian et ses dérivés, il semble que cette version ne soit proposée que pour python 3
Je vais regarder si je peux refaire la manip que j'avais faite à l'époque de la version 14 d'ubuntu, mettre en paquet une version qui fonctionne.
Mais avant ça je vais quand même rechercher ce qui entre gtk2 et gtk3 provoque ce symptôme.

Du coup je comprend pourquoi il me dit que c'est déjà à jour ^^. Je pense que je vais attendre les tests de Claude qui seront plus pertinents que les miens mais je testerai quand même sur une VM pour ne pas planter mon système.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 1.093 secondes

Qui est en ligne ?

Nous avons 86 invités et aucun membre en ligne

Dernières actualités

  • Les nouveautés 2019 de Connecthys (20/01/2019)

    Si vous utilisez Connecthys, le portail famille de Noethys, vous pouvez dès à présent utiliser ces nouvelles fonctionnalités :   Le paiement en ligne :   Le paiement en ligne par carte bancaire pour les...

    Lire la suite...

© 2018 Ivan LUCAS - Tous droits réservés

Recherche