Découvrez et testez Noethysweb, la version fullweb

Plus d'informations
il y a 7 mois 1 semaine - il y a 7 mois 1 semaine #27273 par guerdal
Bonjour
Bon ça me donne une piste.
L'installation ici est un peu particulière avec un proxy nginx qui transfère les demandes au portail vers un autre nginx qui fait proxy pour le gunicorn local qui fait tourner NoethysWeb.

J'ai trouvé un post sur stackoverflow :

By default Django ignores all X-Forwarded headers, base on Django docs.
Force read the X-Forwarded-Host header by setting USE_X_FORWARDED_HOST = True and set SECURE_PROXY_SSL_HEADER = ('HTTP_X_FORWARDED_PROTO', 'https'). So in settings.py:

USE_X_FORWARDED_HOST = True
SECURE_PROXY_SSL_HEADER = ('HTTP_X_FORWARDED_PROTO', 'https')

On va voir si ça résout mon problème
Dernière édition: il y a 7 mois 1 semaine par guerdal.

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.185 secondes
Propulsé par Kunena