Packaging de Noethys

Plus d'informations
il y a 5 ans 10 mois #14032 par j.gioria
Réponse de j.gioria sur le sujet Packaging de Noethys
Bonjour,

j'essai de lancer la compilation et .. paff. il me dit que je n'ai pas le package "plateformes"

une idée ?

merci d'avance :p

ps : n'ayant pas de tag sur le repo, je suis actuellement sur le commit : 8665e7d286671da2a1f73406503fedde2e792b98 du 17/07/2016

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #14033 par j.gioria
Réponse de j.gioria sur le sujet Packaging de Noethys
pour avancer un peu, je suis aller me mettre sur la version 1.1.6.9 (commit 827eee95....) et la il me dit qu'il me manque le package zope.

donc je pense que le package plateformes c'est depuis l'implémentation de connectys...

et pour zope.. que dire, je cherche :p

a+

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #14035 par j.gioria
Réponse de j.gioria sur le sujet Packaging de Noethys
bon a priori, le setup.py ne me semble pas à jour.

en enlevant plateforme="ALL", j'ai pu compilé. et en enlevant include zope.interface.

par contre, il manque la library appdir maintenant dans l’exécutable :(

donc voici les librairies que j'ai :
PS C:\> python -m pip freeze
appdirs==1.4.0
cycler==0.10.0
icalendar==3.10
matplotlib==1.5.1
MySQL-python==1.2.4b4
numpy==1.9.2
ObjectListView==1.2
PIL==1.1.7
Pillow==3.3.0
py2exe==0.6.9
pycrypto==2.6.1
pyExcelerator==0.6.4.1
pyparsing==2.1.5
pypiwin32==219
python-dateutil==2.5.3
pyttsx==1.1
pytz==2016.6.1
reportlab==3.3.0
six==1.10.0
Twisted==16.3.0
zope.interface==4.2.0

Mauvaise version ? il m'en manque ?

si quelqu'un passe par la je suis preneur :p
merci

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #14038 par j.gioria
Réponse de j.gioria sur le sujet Packaging de Noethys
hum, pour zope, j'ai trouvé une solution.

il faut rajouter un fichier vide __init__.py dans le répertoire de package de zope (PYTHONDIR/Lib/site-packages/zope) et cela débloque la situation...

et pour appdirs qui marchait pas, je l'ai réinstallé et c'est bon.

compilation ok pour moi maintenant. et merci pycharm.... j'utilise déjà phpstorm, donc pas dépaysé ...

a+

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #14039 par neoclust
Réponse de neoclust sur le sujet Packaging de Noethys
je pense que le fichier setup a besoin d'un bon nettoyage, car qd je l'utilise sur ma mageia, ca tente de m'installer des trucs dans "/usr/Static/Images"

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 10 mois #14040 par neoclust
Réponse de neoclust sur le sujet Packaging de Noethys
J'ai packagé sans utiliser setup.py pour le moment.

Noethys est maitenant disponible sous mageia ( il sera donc dans mageia 6 et les suivantes ).
Les utilisateur(s) suivant ont remercié: Fred.th

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 9 mois #14056 par bogucool
Réponse de bogucool sur le sujet Packaging de Noethys
Bonjour,

Afin dêtre sûr de bien suivre c'est packagé pip ou mageia ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 9 mois #14057 par neoclust
Réponse de neoclust sur le sujet Packaging de Noethys
Nous avons un rpm dans mageia pour Noethys maintenant.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 5 ans 9 mois #14095 par Ivan
Réponse de Ivan sur le sujet Packaging de Noethys
Bonjour,

Je n'ai pas trop le temps de remettre mon nez dans le setup actuellement mais si vous avez des suggestions, je suis preneur !

Ivan

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.191 secondes
Propulsé par Kunena