Installation sous Debian 10 avec plesk

Plus d'informations
il y a 1 an 2 semaines #25082 par fafa5618
Bonjour, 

Je suis en train d'afficher pour l'instant la page d'atterrissage de Connecthys sur un serveur Debian 10 avec Python 2.7
j'ai suivi ce lien dans l'onglet Linux : https://github.com/Noethys/Connecthys

j'ai changé de serveur récemment et j'avais réussi à faire tournée cette commande sans problème :  python run.py
Et la des que je lance cette commande et que je tape l'adresse du site : https://xxxxx.fr:5000/ : 

<code>
Traceback (most recent call last):
File "/usr/lib/python2.7/SocketServer.py", line 293, in _handle_request_noblock
self.process_request(request, client_address)
File "/usr/lib/python2.7/SocketServer.py", line 321, in process_request
self.finish_request(request, client_address)
File "/usr/lib/python2.7/SocketServer.py", line 334, in finish_request
self.RequestHandlerClass(request, client_address, self)
File "/usr/lib/python2.7/SocketServer.py", line 655, in __init__
self.handle()
File "lib/werkzeug/werkzeug/serving.py", line 217, in handle
rv = BaseHTTPRequestHandler.handle(self)
File "/usr/lib/python2.7/BaseHTTPServer.py", line 340, in handle
self.handle_one_request()
File "lib/werkzeug/werkzeug/serving.py", line 251, in handle_one_request
elif self.parse_request():
File "/usr/lib/python2.7/BaseHTTPServer.py", line 281, in parse_request
"Bad HTTP/0.9 request type (%r)" % command)
File "/usr/lib/python2.7/BaseHTTPServer.py", line 364, in send_error
self.log_error("code %d, message %s", code, message)
File "lib/werkzeug/werkzeug/serving.py", line 273, in log_error
self.log('error', *args)
File "lib/werkzeug/werkzeug/serving.py", line 279, in log
_log(type, '%s - - [%s] %s\n' % (self.address_string(),
File "lib/werkzeug/werkzeug/serving.py", line 267, in address_string
return self.environ
AttributeError: 'WSGIRequestHandler' object has no attribute 'environ'
</code>

Avez vous déja rencontré se problème ? 
merci de votre retour. 

 

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 2 semaines #25083 par fafa5618
je viens de trouver. En tapant :
http://xxxxx.fr:5000/ ca fonctionne mais pas avec le https.

Avez vous une idée ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 semaine #25084 par fafa5618
Désolé pour le Up. Vous avez une idée de comment forcer le HTTPS ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 semaine #25085 par Jakes
Bonjour,
Je n'y connais strictement rien en Linux et en Connecthys mais je sais que pour mon NAS Synology c'est 5000 pour le http et 5001 pour le https.
Maintenant ça n'a peut-être rien à voir...

Pour une aide sur le paramétrage, poster le fichier que vous avez déjà créé en pièce jointe= Paramétrage/Activités/ bouton d'export sur la droite
Génération d'un fichier .nxa à joindre au message = Action/Répondre/Pièces jointes/Ajouter des fichiers/Insérer/Soumettre

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 semaine - il y a 1 an 1 semaine #25086 par fafa5618
Merci de ton message jakes mais non cela ne fonctionne pas :)

Ce que je ne comprends pas c'est comment transformer une url http://xxxx.fr:5000 en https://www.montigne-portail-famille.fr/login par exemple. Cela doit venir du Vhost ?
Dernière édition: il y a 1 an 1 semaine par fafa5618.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 1 semaine #25087 par Jakes
En plein brouillard !!!   

https://community.ovh.com/t/redirection-dun-site-http-vers-https/15568

 

Pour une aide sur le paramétrage, poster le fichier que vous avez déjà créé en pièce jointe= Paramétrage/Activités/ bouton d'export sur la droite
Génération d'un fichier .nxa à joindre au message = Action/Répondre/Pièces jointes/Ajouter des fichiers/Insérer/Soumettre

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 6 jours #25110 par fafa5618
Tu m'étonnes jakes :)

Mon Vhost pointe sur le dossier "connecthys"
je suis sur un plesk + apache + php 7.4.2. J'ai activé CGI et FastCGI + redirection auto du http vers le https.

Quue je fasse https://xxx.fr:5000. ou https://xxx.fr: ou https://xxx.fr:5000/connecthys.cgi j'ai une erreur 500 : End of script output before headers: connecthys.cgi

Je ne vois vraiment pas. Avez vous des idées ?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 6 jours #25112 par Jakes
Chez moi c'est :
https://xxxx.connecthys.com
https://www.xxx.connecthys.com/accueil_famille

Pour une aide sur le paramétrage, poster le fichier que vous avez déjà créé en pièce jointe= Paramétrage/Activités/ bouton d'export sur la droite
Génération d'un fichier .nxa à joindre au message = Action/Répondre/Pièces jointes/Ajouter des fichiers/Insérer/Soumettre

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 6 jours #25113 par fafa5618
dans ton réglage sur Noethys tu as ca ? https://ibb.co/rdVqqfV
tu mets quoi à la fin de ton url un "/"

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 6 jours #25114 par fafa5618
Dans les logs sur serveur j'ai : End of script output before headers: connecthys.cgi
Cela te parle ?

Connexion ou Créer un compte pour participer à la conversation.

Temps de génération de la page : 0.185 secondes
Propulsé par Kunena